mibuso.com

Microsoft Business Solutions online community
It is currently Tue Sep 16, 2014 9:29 pm

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 3:32 pm 
Offline

Joined: Wed May 26, 2004 11:27 am
Posts: 142
Location: Zug - Switzerland
Country: Switzerland (ch)
Hi,

We are using Microsoft Payment Services for credit cards and it is working on the NAV server where everything has been set up. However as soon we try to enter or use a credit card on any of the clients we get the following error message:

This message is for ... Unable to create an instance of Automation Server
Microsoft.Dynamics.NAV.Encryption.RSAMachineKeyProvider with CLSID = .. Exception has been thron by the target of an invocation.

Any ideas? Microsoft support keeps telling me that they have no experience with Payment Services.


Top
 Profile  
 
 Post subject: Re: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 4:32 pm 
Offline

Joined: Fri Nov 13, 2009 3:04 pm
Posts: 76
Location: Barcelona
Country: Spain (es)
Have you tried to compile the object that instantiates the variable? Moreover from the client pc in case of Classic client or in case of the RTC from the machine that hosts middle tier...


Top
 Profile E-mail  
 
 Post subject: Re: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 6:42 pm 
Offline

Joined: Wed May 26, 2004 11:27 am
Posts: 142
Location: Zug - Switzerland
Country: Switzerland (ch)
We are using RTC and I did compile all the objects on the Service Tier. They all compiled without errors but it is still not working.

Any other ideas?


Top
 Profile  
 
 Post subject: Re: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 6:55 pm 
Offline

Joined: Fri Nov 13, 2009 3:04 pm
Posts: 76
Location: Barcelona
Country: Spain (es)
I would try to create simple object (form, report, codeunit) and run the code that creates new instance of the automation from classic client on the "service" machine. I haven`t have any problem to instantiate my variable of the automation.

There is sth. next that defines NAV help:
Quote:
To work with payment services, you must start the Microsoft Dynamics NAV Server service with an Active Directory domain network account instead of with the Network Service account. If you have not set up a domain network account, then you will see the following error message:

Error Code=1020; Message = We encountered a problem resolving the host name. Contact your administrator if the problem persists.


I understand that it is not you case but...


Top
 Profile E-mail  
 
 Post subject: Re: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 7:05 pm 
Offline

Joined: Fri Nov 13, 2009 3:04 pm
Posts: 76
Location: Barcelona
Country: Spain (es)
Or may be a problem of permissions... What kind of the account do you use to run the service?


Top
 Profile E-mail  
 
 Post subject: Re: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 11:19 pm 
Offline

Joined: Wed May 26, 2004 11:27 am
Posts: 142
Location: Zug - Switzerland
Country: Switzerland (ch)
After some testing we figured out the issue. It was a permission issue. The regular domain users had no access to the following path on the server that runs the service tier:

C:\Program Files\Common Files\Microsoft Dynamics NAV\Dynamics Online Payment Client

When searching for the CLSID of the error message in the registry, it shows the path it requires access. After we changed this, the Authorization worked on all clients.


Top
 Profile  
 
 Post subject: Re: Encryption error with Microsoft Payment Services
PostPosted: Wed Jun 06, 2012 11:22 pm 
Offline

Joined: Fri Nov 13, 2009 3:04 pm
Posts: 76
Location: Barcelona
Country: Spain (es)
Ok, i supposed that could be problem of the permissions because i had faced not completely the same but a similar one problem... Thanks for your reply.


Top
 Profile E-mail  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum


Search for:
Jump to: