mibuso.com

Microsoft Business Solutions online community
It is currently Sun Oct 26, 2014 6:23 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: How to solve this issue in Webservice?
PostPosted: Thu Oct 16, 2014 10:31 am 
Offline

Joined: Thu Jan 15, 2009 7:12 am
Posts: 168
Country: India (in)
Hi Friends,

After publishing an Page in NAV, I gave the below URL in a browser.

http://<Server>:7047/DynamicsNAV/WS/Nav_Company/Page/ItemTest

I am getting this error.

Code: Select all
<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
  <s:Body>
    <s:Fault>
      <faultcode xmlns:a="urn:microsoft-dynamics-schemas/error">
        a:Microsoft.Dynamics.Nav.Types.Exceptions.NavCSideException
      </faultcode>
      <faultstring xml:lang="en-US">
        The trace flag 4616 is not set on the database server XXXXX. You must set this flag and restart the server before you can connect to the database.
      </faultstring>
      <detail>
        <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/">
          The trace flag 4616 is not set on the database server XXXXX. You must set this flag and restart the server before you can connect to the database.
        </string>
      </detail>
    </s:Fault>
  </s:Body>
</s:Envelope>


Can anyone tell me how to solve this?

Thanks in advance.


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Thu Oct 16, 2014 11:27 am 
Offline

Joined: Mon Jul 12, 2010 2:47 pm
Posts: 366
Location: Noida
Country: India (in)
Hi,

This is a sql server settings. Refer below article.

http://saurav-nav.blogspot.in/2011/05/trace-flag-in-sql-server-for-dynamics.html

let me know if any issues.

_________________
Thanks & Regards,
Saurav Dhyani

http://saurav-nav.blogspot.in


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Thu Oct 16, 2014 12:06 pm 
Offline

Joined: Thu Jan 15, 2009 7:12 am
Posts: 168
Country: India (in)
Thanks you Saurav.

What version of Microsoft SQL Server should be there? Because in my system I have Microsoft SQL Server 2008 and Microsoft SQL Server 2012. As mentioned, I have given -T4616 in the Setup Parmeters and restarted the services.

Still I am getting the same issue.... ](*,)


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Thu Oct 16, 2014 12:16 pm 
Offline

Joined: Mon Jul 12, 2010 2:47 pm
Posts: 366
Location: Noida
Country: India (in)
Hi,

Try Login into Navision Classic Client using the account that you are using to run web services. Let me know the findings.

_________________
Thanks & Regards,
Saurav Dhyani

http://saurav-nav.blogspot.in


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Thu Oct 16, 2014 3:25 pm 
Offline

Joined: Thu Jan 15, 2009 7:12 am
Posts: 168
Country: India (in)
Am using Navision Classic Client only...


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Thu Oct 16, 2014 6:32 pm 
Offline

Joined: Mon Jul 12, 2010 2:47 pm
Posts: 366
Location: Noida
Country: India (in)
Hi,

Did you tried login with the account with which services are running.

Suppose my services (Nav service and web service) are running with DomainName\Username.

So trying in login in with DomainName\Username.

_________________
Thanks & Regards,
Saurav Dhyani

http://saurav-nav.blogspot.in


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Fri Oct 17, 2014 7:32 am 
Offline

Joined: Thu Jan 15, 2009 7:12 am
Posts: 168
Country: India (in)
Hi Saurav,

Both Nav service and web service are running with same DomainName\Username.

Still issue persists?!?!?


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Fri Oct 17, 2014 5:15 pm 
Offline

Joined: Mon Jul 12, 2010 2:47 pm
Posts: 366
Location: Noida
Country: India (in)
Hi Aravindh,

What i meant is Open Navision Classic or RTC Client with the DomainName\UserName used for running Services.

I think the issue is with the user and the user (used to run Services) is not a part of Navision Database OR user does not have sufficient permission.

TRY Login into Navision client with user and let me know the results.

_________________
Thanks & Regards,
Saurav Dhyani

http://saurav-nav.blogspot.in


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Mon Oct 20, 2014 8:05 am 
Offline

Joined: Thu Jan 15, 2009 7:12 am
Posts: 168
Country: India (in)
Hi Saurav,

Yeah the DomainName\UserName which I am using in the services is not there in the Navision database.

Navision SQL database is in a server XXXXX. I am accessing from my local machine. I have published Page Item card. When I tried to access using the URL:

http://<Server>:7047/DynamicsNAV/WS/Nav_Company/Page/ItemTest

.. I am not getting the proper detail in the browser.

But my colleague from other system tried to access using the same URL, but he is getting the correct details.


Top
 Profile E-mail  
 
 Post subject: Re: How to solve this issue in Webservice?
PostPosted: Mon Oct 20, 2014 7:31 pm 
Offline

Joined: Mon Jul 12, 2010 2:47 pm
Posts: 366
Location: Noida
Country: India (in)
Hi Aravindh,

Your colleague might be using a different service to connect to the database.

Resolution steps -

1. The User that you are using to run service should be added in Navision Database with Sufficient Rights to execute the pages that web services is using.
2. Create the user in Navision Windows Login and assign rights.
3. Synchronize the login.
3. Restart the service tier once you are done.

Now try to run the page. Hope it helps.

_________________
Thanks & Regards,
Saurav Dhyani

http://saurav-nav.blogspot.in


Top
 Profile E-mail  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum


Search for:
Jump to: