mibuso.com

Microsoft Business Solutions online community
It is currently Tue Jul 29, 2014 4:35 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Business Notification - success !
PostPosted: Fri May 19, 2006 4:27 pm 
Offline

Joined: Wed Jan 04, 2006 11:19 pm
Posts: 28
Location: Cambridge
Country: United Kingdom (uk)
Hi there i have noted that so many people seem to have problems installing this ( i was one of them) however i seem to have cracked it.

Firstly make sure that if running version 4 no service packs that you have the designer.dll hoftix other Other wise you will have problems with the notication manager.

Also make sure that you have US language on IE - Tools, internet Options, language add us and make sure to move it to the top. ( this only applied to people in Europe) if you dont do this the webpage will show as blank when trying to subscribe.

When loading The business Notification copy the CD to the Root Drive and this will prevent any corruptions with the install.

Also put a copy of the customers license file into the Business Notification NAS Directory Not NAS as we know if BN has a seperate application server. Make sure that you rename this file to Cronus.flf

Make sure that the license file has two granules for BN ( Worksheet Lines) 7110 and 7010 without these it will not work at all.

When installing make sure to avoid using IP adress or local host as this causes problems with the sending and receiving of emails.

Once installed create a New BN USER in Active directory and Give them Super user rights and all admin rights for BN in navision.

Go to admin tools and services and locate the two services that are required for BN ( NS$Business Notification service and Notification service) Go to properties and log on for each and assign the BN USER as the log on for these services.

Make sure that you can reach your email server Telnetmailserver25 from the cmd prompt.

Make sure that you go to BN Setup from navision and enable Send notification once you have created Schema from BN Manager, Make sure that the schema is started then close out and go to Navision and suggest lines from the notification worksheet, you should see that if you have correctly created the schema there will be lines available to send, send these lines.

Check the message store in SQL Which is where they hit first if there is nothing in here check the transmission log which is where they will go if they are being sent to Exchange, Now check the event viewer if they have succesfully reached the BN Log in event viewer you will have a message saying so...If not check the event log for details ....

I think that I have tried to cover everything in there ..no doubt there will be things i may have missed please feel free to email me if you need any help.

:D


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 19, 2006 4:53 pm 
Offline

Joined: Tue Feb 22, 2000 8:01 am
Posts: 991
Location: Jurmala/Riga
Country: Latvia (lv)
Quote:
Also make sure that you have US language on IE - Tools, internet Options, language add us and make sure to move it to the top. ( this only applied to people in Europe) if you dont do this the webpage will show as blank when trying to subscribe.


Man... You're.... MAN!

I had only this strange problem before. :)

Perfect job!

_________________
"You can’t just ask customers what they want and then try to give that to them.
By the time you get it built, they’ll want something new.” Steve Jobs


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 19, 2006 5:00 pm 
Offline

Joined: Tue Feb 22, 2000 8:01 am
Posts: 991
Location: Jurmala/Riga
Country: Latvia (lv)
Oops... Sorry :oops:

I've forgot to look at name...

Nothing personal! :oops:

_________________
"You can’t just ask customers what they want and then try to give that to them.
By the time you get it built, they’ll want something new.” Steve Jobs


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 22, 2006 1:34 pm 
Offline
Moderator
MVP Microsoft Dynamics NAV
NAV TechDays 2014 attendee

Joined: Wed Jul 02, 2003 10:13 am
Posts: 7683
Location: Milan
Country: Italy (it)
[Topic moved from Navision forum to Navision Tips & Tricks forum. A good Tips&Trick]

_________________
Regards,Alain Krikilion
Use the SEARCH,Luke! || No PM,please use the forum. || May the <SOLVED>-attribute be in your title! || Read Forum Rules before making a posting

»»» Mark your calendar: NAV TechDays 2014 - 20 & 21 November 2014 ««« Visit the conference website: http://www.navtechdays.com


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 22, 2006 1:36 pm 
Offline

Joined: Wed Jan 04, 2006 11:19 pm
Posts: 28
Location: Cambridge
Country: United Kingdom (uk)
i'll forgive you ;)


Top
 Profile  
 
 Post subject: Thanks
PostPosted: Tue Jun 27, 2006 4:59 am 
Offline

Joined: Tue Jun 27, 2006 4:55 am
Posts: 14
Location: New Zealand
Country: New Zealand (nz)
Thanks Lisa.

The US Language option fix for a blank Subscribe screen also applies to New Zealand.

Cheers, Gareth.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 04, 2007 8:23 am 
Offline

Joined: Mon Oct 01, 2007 11:32 am
Posts: 9
Location: Singapore
Country: Singapore (sg)
Hi Lisa

Thank's for your detailed help on BN i am facing a problem on sending E-
Mail can u tell how to configure SMTP Server or where i can find the (telnetmailserver25) service that u talked about


With regrds


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 16, 2007 9:24 am 
Offline

Joined: Mon Aug 06, 2007 10:38 am
Posts: 51
Location: Norway
Country: Sweden (se)
arvinder_singh wrote:
Hi Lisa

Thank's for your detailed help on BN i am facing a problem on sending E-
Mail can u tell how to configure SMTP Server or where i can find the (telnetmailserver25) service that u talked about


With regrds


Good morning Arvinder!

If I understand your last question on this thread, you wanted to know how to use the Telnet commando in order to check for connection to your exchange/mail server?

In order to Telnet your mailserver you open up a command window (CMD on the Start-menu), wright "Telnet mailserver 25", then hit the Enter key. If you receive an answer from your mailserver than you have a connection between the mailserver and the server you are trying this from, hense you have a succefull connection, hense you should be able to send emails from Navision and also receive the emails with a email account!


Top
 Profile E-mail  
 
 Post subject: Success!!!
PostPosted: Tue Oct 16, 2007 3:23 pm 
Offline

Joined: Mon Aug 06, 2007 10:38 am
Posts: 51
Location: Norway
Country: Sweden (se)
A few hints on the way!

Use a local administrator while installing Business Notification Manager.

Change the logon account to domain admin on the service:
"Notification Service Deployment Manager".

And also change the logon account to domain admin on the service:
"NS$BusinessNotificationInstance".

Don't forget to change the ASP.NET settings on the three websites (created by BNM installation) to version 2 of .net.

Don't miss to put in the whole domain name for the exchange server i.e. servernamn.domainname.local.

Also do this for the native settings for Navision - if the Navision database are located on another server.

While creating schemes do not try to use a email adress in plain text for the external recipient i.e name@company.com. The BNM will not recognize the format and stop the whole notification process (this is actually creating an event in the event viewer). Better to put in a test email adress into one customer account in Navision and use that customer for test purposes.

As far as I can determine you have to add single users and no groups as recipients in Business Notification Manager.

And last but not least. I have just now installed Business Notification Manager on the production server, started up a few schemes for test purposes and evaluation. Then it's up to my colleques (the Navision experts) to set up a bunch of real schemes and notifications for the users to use :)


Top
 Profile E-mail  
 
 Post subject:
PostPosted: Wed Feb 20, 2008 7:49 am 
Offline

Joined: Tue Nov 08, 2005 9:03 am
Posts: 20
Location: Jurong
Country: Singapore (sg)
i have a problem with BN not sending e-mails. the messages goes through message log and the transfer log but no e-mail is sent. also, the Business Notification Event log is empty. Waht could be the problem?



FIXED!

it was a problem with permissions in IIS.


Top
 Profile  
 
 Post subject: Re: Business Notification - success !
PostPosted: Thu Oct 02, 2008 11:03 am 
Offline

Joined: Wed Jul 30, 2008 4:04 pm
Posts: 27
Location: HYDERABAD
Country: India (in)
hi Lisa ..

I have a problem with BN when iam trying to create to create a new schema.The error is "An Error occured while trying to connect to Navision. plz make sure that your navision client is running".

My Navision client also running......

what is the problem..?

plz kindly give reply...


Top
 Profile  
 
 Post subject: Re: Business Notification - success !
PostPosted: Thu Mar 12, 2009 5:41 pm 
Offline

Joined: Thu Sep 07, 2006 11:58 am
Posts: 471
Location: Stabio
Country: Switzerland (ch)
I ask you if partner standard license (our does not contain explicitly granule no. 7110 and 7010) can run however the business notification server.
We have to make some internal test.

Thank you.


Top
 Profile  
 
 Post subject: Re: Business Notification - success ! - NASSQL not schedule
PostPosted: Thu May 14, 2009 12:50 pm 
Offline

Joined: Thu Sep 07, 2006 11:58 am
Posts: 471
Location: Stabio
Country: Switzerland (ch)
Hello,

I installed successfully NAV BN 5.0 with server SQL.

The problem is that after that, the NASSQL that was installed before, for scheduling jobs fails to schedule.

I have seen that BN has installed another NASSQL in his subfolder. I already copied our license file to this folder and renamed it as Cronus.flf as you said but I have again problem with the original NASSQL (external to BN).

My questions are:

- BN and NASSQL are compatibles on same machine with same domain user running them?
- BN can not use same NASSQL (only one instance) already present? If yes, how is it possible to set this?
- Other suggestions?

My problems are that NASSQL original, present as Windows service fails both to schedule job in JOBQUEUE 5.0 and also fails to stop.. the status remains stopping for a long time and then I have to kill it.

Thank you very much


Top
 Profile  
 
 Post subject: Re: Business Notification - success !
PostPosted: Tue Aug 25, 2009 12:41 pm 
Offline

Joined: Wed Dec 03, 2008 9:48 am
Posts: 92
Lisa Randall wrote:
Check the message store in SQL Which is where they hit first if there is nothing in here check the transmission log which is where they will go if they are being sent to Exchange, Now check the event viewer if they have succesfully reached the BN Log in event viewer you will have a message saying so...If not check the event log for details ....
:D


Hi Lisa & All,

I am trying to send mail via BN.There are data in "Transmission Log" but no mail is generated.

In Event Viewer I got the following message

A delivery failure was reported.
EventParameters:
Distributor ID: 1
Distributor Name: SERVER
Delivery Channel Name: SMTPNotificationChannel
Notification ID: 488
Notification Class Name: NotificationsOfScheme94c79bd9_d017_47af_ab34_9decc9ea56fc
Notification Status Info:
........
InstanceName: BusinessNotificationInstance
ApplicationName: MBSBN
Component: Distributor
ComponentDetails: DistributorName: SERVER
Thread: 5
For more information, see Help and Support Center at


How to overcome frm this situation? Plz reply.. ](*,)


Top
 Profile E-mail  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum


Search for:
Jump to: