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+ Getting started
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Why Power
Platform and
Power Apps?




Microsoft Power Platform

The world’s most complete set of integrated, low-code development tools

» ¥ »

Power BI Power Apps Power Automate Power Virtual Agents Power Pages
Business Application Workflow Intelligent virtual Secure external
analytics development automation agents business websites

td €© O N1 @

Connectors Al Builder Microsoft Power Fx Managed
Dataverse Environments

Q Additional capabilities

Every developer
(low-code)

Pro developer
(code-first)




1000

900+ built-in
connectors
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When should you consider using Power Apps?



‘, Power App for Business Central R

- Full flexibility to create customized Ul/UX

- Easy access to additional data via connectors

* Rich platform capabilities
* Ul controls with device integration AMSTERDAM Lamp
+ Out of the box augmented reality o
- Integration to Al Builder —

* Runs on devices, in Teams and in web player

- Power Apps usage rights are included in Business Central
Essential and Premium licenses



Announcing Power App samples for Business Central

Public preview

Take Warehouse Coffee MR
order helper (coming soon)




Announcing Power App samples for Business Central

Public preview

Easy starting point for partners

Practice what you preach

Best practices for developing with Business Central

Build using the Al-go for GitHub templates



Announcing Power App samples for Business Central

Public preview

Warehouse Helper

Simple app that lets you scan items
and update inventory

Meant as foundation not end-user
product




Announcing Power App samples for Business Central

Public preview

Take Order

More complete scenario that lets

restaurant servers assign tables and
take orders




Announcing Power App samples for Business Central

Public preview

Take Warehouse Coffee MR
order helper (coming soon)

Try them now!: https://github.com/topics/bcsamples


https://github.com/topics/bcsamples

What does it take
to build a
repeatable Power

App




Power App for Business Central Design
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Major investments wave over wave:
Support image and pdf attachments (new)

Support more data (new)

Supports translations and captions (new)

Supports custom APIs
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Internal: Include Power App in your dev process

(10

Power App

—_

AL Extension

“One Solutio

>

- &

—_—

O
______________ --------------

Environment 000 Environment

\

Build -> Verify -> Test Internally -> Main release ->
Updates -> Build New Version -> (start all over)



Main challenges: AL APIs
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Not a problem:

Tons of tools to expose

APIs rd

Still a development effort
(no low code yet, but
coming soon)

Community tools to auto
create APl pages

AL Extension
APls

-
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Main challenges: Power App code
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(Was)Not a problem:

 Power Platform team
continue to invest in ALM
tools wave after wave

« Great tools to manage
source code

« https://learn.microsoft.co
m/en-us/power-
platform/alm

|
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AL Extension
APls

.

/




@ A () https://learn.microsoft.com/en-us/power-platform/alm/ O A 16 = g

Power Platform Getstarted v Products v

“% Filter by title

Application lifecycle management (ALM)
Overview
ALM basics
Environment strategy
> Solutions

Tools and apps used

> Implementing healthy project and solution ALM

> Implementing healthy component ALM
~ ALM for admins and makers
ALM for admins and makers
Manage solutions using PowerShell
> Deploy solutions using pipelines
v ALM for developers
ALM for developers
> Build Tools
> GitHub Actions
> Work with solution components
> Leverage solution and packaging tools
> Verify quality of solutions and packages
> Manage solutions using code
Edit the customizations file

Pipeline table reference

Guidance Troubleshooting ~ Resources v

Learn / Power Platform / v

Application lifecycle management (ALM) with Microsoft Power
Platform

Learn how to implement application lifecycle management (ALM) using Microsoft Power Platform (Power Apps, Power Automate,
Dataverse, Power Virtual Agents).

About ALM with Power Understand and work with Implement healthy ALM
Platform solutions

{8} concepT
] oveRvIEW & concepr Scenario 0: ALM for a new project
What is ALM? Solution concepts

Scenario 1: Citizen development ALM

Understand solution layers . . ,
Scenario 2: Moving from a single

{E} CONCEPT environment

Use solutions to customize

ALM basics with Power Platform Scenario 3: Moving from unmanaged to

Segment solutions .
) managed solutions
Environment strategy

Scenario 4: Use DevOps for automation

[($] REFERENCE Scenario 5: Support team development
Tools and apps used for ALM ALM automation Scenario 6: Embrace citizen developers
@] oVERVIEW
Use Power Platform Build Tools for Azure
DevOps
For developers Related docs

Use GitHub Actions for Power Platform



Main challenges: BC Connector
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Real problem:

BC connection requires a %
very specific data

-

{environment and

company} \
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AL Extension
APls

~

/

The connection reference is
“hard coded” within a
Power App

No way to for user to
configure in Ul that
connection



File Edit Selection View Go Run Terminal Help Connections.json - BcSamplePowerApps - Visual Studio Code

p {} Connectionsjson X

BcSampleAppsSolution > CanvasApps > src > new_takemyorder 5a368 > Connections > {} Connections.json > {} 6cb6806c-e815-4e58-8693-91bcb31c69e7 > [ ] dataSources

) 38 "dependents": [],
39 "id": "150e2896-54f3-405b-alae-bdda9e197568"
40 ¥,
g 41 "6cb68066c-e815-4e58-8693-91bcb31c69e7": {
42 "connectionRef": {
- 43 "apiTier": "Premium",
44 "displayName": "Dynamics 365 Business Central",
m 45 "iconUri": "https://connectoricons-prod.azureedge.net/releases/v1.0.1624/1.0.1624.3220/dynamicssmbsaas/icon.png",
] 46 "id": "/providers/microsoft.powerapps/apis/shared_dynamicssmbsaas",
47 "parameterHints": {},
J 48 "parameterHintsv2": {}
49
50 “"datasets": {
51 "Sandbox,dc5@d5e8-f9c9-ed11-94cc-000d3a226b2f": {

52 "dataSources™: {

54 "tableName": "customersWithImage,microsoft%252FpowerApps%252Fbeta”
55 T,

56 "itemsWithImage (microsoft/powerApps/beta)": {

57 "tableName": "itemsWithImage,microsoft%252FpowerApps%252Fbeta"

58 s

59 "localizationInformations (microsoft/powerApps/beta)": {

60 "tableName": "localizationInformations,microsoft%252FpowerApps%252Fbeta”
61 1.

62 "powerapplLanguageResources (microsoft/powerApps/beta)": {

63 "tableName": "powerapplLanguageResources,microsoft%252FpowerApps%252Fbeta”
64 1,

65 "salesOrderLines (v2.0)": {

66 "tableName": "salesOrderLines,v2.0"

67 1,

68 "salesOrders (v2.8)": {

69 “"tableName": "salesOrders,v2.0"

70 }

71 }

72 }

73 Js

74 "dataSources": I

75 "customersWithImage (microsoft/powerApps/beta)",

76 "itemsWithImage (microsoft/powerApps/beta)"”,

77 "salesOrders (v2.0)",

— [ D T T T P )



Manual work needed to move “solution”

Manual work required to
— compile an “app” and

{Q o } gggr;ge connections in the i————— ———————— |

“One Solution” L .‘4 i
Power App — |
s‘ ;

-

AL Extension

—_—




AL-Go for GitHub and Power Platform

Full ALM support for Power Platform solutions for Per Tenant Extensions

Preview N

A single repository for your AL and

< CI/CD

@ AddOpenAlPromotionMessageForltem #17 Power Platform art|faCtS

One set of configuration for all

(A Summa ry

Deploy to Steffen

Jobe succeeded yesterday in 2m 49s ©o S log yo u r enVi ro n ments
@ Initialization : . re
e s Unified management and deployment of
© suid - Defau ? @ Credon your solutions across BC and Power Platform
@ Build BcPromotions - Default > @ Download artifacts
l @ Deploy to Steffen > EnvName FOR VARS

@) Deliver to ${{ matrix.deliveryTar... > Read settings

Read secrets

FOR ISVS
Coming soon

Deploy AL

&Y Workflow file

o
o
o
> @ AuthContext
o
)

Deploy PowerPlatform

Try the preview with your AL and
Power Platform code today



https://github.com/microsoft/AL-Go-PTE-PPPreview

Demo : Internal - Working with Power Apps
across environments



Under the hood - Pull

o AL-Go for GitHub 5 Dev environment

“One Solution”

Power App “ “Save changes” i .‘?‘ i

- .4 .

AL Extension Environment

—_—

______________




Demo : External - Working with Power Apps
across environments



Under the hood - Publish

o AL-Go for GitHub 5 New environment

{(, c:} iy I .

u ion” "Deploy changes”
Power App Onlut|on ploy g

BN
- § = BN
% « Update connections i i
with a right O i

o

company/environment

______________

AL Extension etc Environment

—_—




Getting your solution to your customer!

Modify PP
‘Package and  solution

. Publish PP connections
Locate solution
Source for
O . PP solution
Compile
and
Publish AL
®locate  App
Source
for AL

App



With AL-Go for GitHub

Run Publish
workflow in

.Optionalz Setup AL-Go for GitHub

authentication



Getting started




Getting started

Public preview

1. Get a repository

2. Configure your environment

3. Add you code



Getting started

Public preview



https://aka.ms/BcPapps

We are excited to see what you can build!!



Any Questions?



Thanlk
Youl!




! ! Lorem ipsum dolor sit amet, consectetuer
adipiscing elit. Maecenas porttitor congue

massa. Fusce posuere, magna sed pulvinar
ultricies, purus lectus malesuada libero, sit
amet commodo magna eros quis urna.

Name
Company or position



! ! Lorem ipsum dolor sit amet, consectetuer
adipiscing elit. Maecenas porttitor congue

massa. Fusce posuere, magna sed pulvinar
ultricies, purus lectus malesuada libero, sit
amet commodo magna eros quis urna.

Name
Company or position



! ! Lorem ipsum dolor sit amet, consectetuer
adipiscing elit. Maecenas porttitor congue

massa. Fusce posuere, magna sed pulvinar
ultricies, purus lectus malesuada libero, sit
amet commodo magna eros quis urna.

Name
Company or position



Lorem ipsum dolor sit amet, consectetuer adipiscing elit.
Maecenas porttitor congue massa. Fusce posuere, magna
sed pulvinar ultricies, purus lectus malesuada libero, sit amet
commodo magna eros quis urna.

Name
Company or position



mibusc.com

Any Questions?
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Thank you



Screenshot layout

O & nhttps;//family.microsoft.com/

Family Safety

Kasper

Update this device frame
placeholder to display a tablet
or desktop screenshot. 16:9 Ul
screens work best.

Kasper

Overview

Screen time

You may adjust the frame'’s
placement on the slide, and/or
the slide color to another

template accent. : opw age s




Mobile screenshot layout

Update this device frame placeholder
to display a mobile screenshot.

You may adjust the frame’s placement
on the slide, and/or the slide color to
another template accent.

@ microsoft.com

B Microsoft




Chart design

Sales Chart Title

N

w

N

—

(@)



Event name or
presentation title

Subtitle or speaker name

§ 2023

mibusc.com



Agenda - Click to add text



Text layout (without bullet points)

Main topic: Segoe Ul, size 28pt

Segoe Ul, size 20pt for second level
Segoe Ul, size 16pt for third level



Text layout with bulleted text

- Learn how to adjust list levels
- Follow the steps on the right

=5 t=. “Il_e
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I
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|
i
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... = A . a-
== Increase List Level

Decrease List Level

Decrease the indent level. ncrease the indent level.
Pa

= T

Use the "Decrease List Level’ and “Increase List Level” tools
on the Home menu to change text levels.

Try this:

1. Place your cursor in the line of text that says “Segoe Ul, size
20pt for second level”

2. Next click the Home tab, and then on the “Decrease List
level” tool. Notice how the line moves up one level.

3. Now try placing your cursor in one of the top “Main topic..."
line of text. Click the “Increase List Level” tool and see how

the text is pushed in one level.

Use these 2 tools to adjust your text levels as you work



Two text columns with subheads

Add a subhead here Add a second subhead here

- This placeholder is designed with - Keep the top edge of text
bulleted text blocks aligned

- It's easy to remove bullets - More text

- Select the text, then on the Home - More text

menu, click the bullet list icon



Three text columns with subheads

Space for a two-line Wrap short Adjust lower text

subhead here subheads blocks up or down

+ This placeholder is - Keep the top edge of text - Keep the top edge of text
designed with bulleted text blocks aligned blocks aligned

- It's easy to remove bullets - More text -+ More text

- Select the text, then on the - More text - More text

Home menu, click the
bullet list icon



Four text columns with subheads

Space for a two-line Wrap short Consistent line Adjust lower text up

subhead here subheads wraps look better or down as needed

- This placeholder is - Keep the top edge of - Keep the top edge of - Keep the top edge of
designed with text blocks aligned text blocks aligned text blocks aligned
bulleted text - More text - More text - More text

+ It's easy to remove - More text - More text - More text
bullets

- Select the text, then on
the Home menu, click
the bullet list icon
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Two photos side-by-side layout

Click Home > Layout to find more photo layouts Text placeholder



Three photos layout

Click Home > Layout to find Text placeholder Text placeholder
more photo layouts



Four photos layout

Click Home > Layout to  Text placeholder Text placeholder Text placeholder
find more photo layouts



Four round photos

Click Home > Layout Text placeholder Text placeholder Text placeholder
to find more round
photo layouts



Two filmstrip photos

Click Home > Layout to find filmstrip layouts Text placeholder
for three, four and five photos



Click Home >

Layout to find
filmstrip layouts
for two, three
and four photos

Five filmstrip photos

Text placeholder

Text placeholder

Text placeholder

Text placeholder



Top photo with Title



Full bleed ower Title




Slide palette info

The PowerPoint palette for this template has been built for you and is shown below.
Avoid using too many colors in your presentation.

PowerPoint Theme Accent colors

Accent 1 Accent 2 Accent 3
Accent 4 Accent 5 Accent 6

Use Accent 1 as the main accent color. Use Accents 4-6 sparingly

Use Accent 2 and Accent 3 only when
additional colors are needed.



Ensure slide content is accessible

Take the following steps to create accessible content that everyone can consume effectively.

Contrast

Use high contrast colors for
maximum readability

The recommended contrast
ratio is at least 4.5:1

Tet “/

Color Contrast Analyzer

Download this tool to determine
the legibility of text and the
contrast of visual elements

i Download

Additional tips

Shape and color

Use different shapes with a
legend to indicate statuses
to accommodate for color
blindness

Example:
Subject 1 o
Subject 2 A
Subject 3 X

® C1 A C2 X C3

Alt text

Alt text helps people with
screen readers understand
the content of slides

You should create alternative
text for shapes, pictures,
charts, tables, SmartArt
graphics, or other objects

Here’s how:

Right click on item
Select Edit Alt Text
Enter a Description

If an object is meant to add visual
styling and doesn’t contain
meaning (e.g. stylistic borders), do
not add alt text and instead check
Mark as decorative

Slide layouts

Using a built-in slide layout
that matches your content
ensures a hierarchical
reading order of text blocks

Example:

If a new slide will have a title,
rather than starting with a blank
layout and adding a text block for
the title, choose one of the built-in
layouts with a title placeholder

Click to add title

Be sure to run the Accessibility Checker! Go to File = click the Check for Issues drop down menu -> click Check Accessibility

Videos need to be accessible: If your presentation includes a video, ensure it is captioned and audio described (if appropriate)

Visit the Office Accessibility Center to learn more about accessibility in PowerPoint

Reading order

Screen readers describe
content on the screen in the
order it was created

To ensure your content is
read back in the order you
prefer, arrange your objects
in the Selection Pane
appropriately. Objects on the
bottom of the selection pane
are read first

Here's how:
Click the Home tab

In the Drawing group, select the
Arrange drop-down menu

Click Selection Pane...


http://www.paciellogroup.com/resources/contrastAnalyser
http://www.paciellogroup.com/resources/contrastAnalyser
https://support.office.com/en-US/article/Make-your-PowerPoint-presentations-accessible-6f7772b2-2f33-4bd2-8ca7-dae3b2b3ef25

Brand and accent colors accessibility

Type and background combinations must
meet a minimum 4.5:1 contrast ratio to help
ensure people of all abilities can access and
understand our communications.

Pick colors carefully and avoid relying on
color alone to convey information. Always
provide text or other graphical cues to guide
customers to our message.

Examples demonstrate correct color use
for on-screen applications.

Get the Color Contrast Analyzer

Get more information on accessibility

Get the Microsoft color quidelines PDF

Dark Orange
Rich Black
R255 G147 B73
Hex #FF9349

White

R216 G59 B1
Hex #D83B01

Light Orange
White

R107 G41 B41
Hex #6B2929

Dark Yellow
Rich Black
R254 G240 BO
Hex #FEFO00

Rich Black
R255 G185 BO
Hex #FFB900

Light Yellow
White

R106 G75 B22
Hex #6A4B16

Dark Green
Rich Black
R155 G240 B11
Hex #9BFOOB

White
R16 G124 B16
Hex #107C10

Light Green
White

R5 G75 B22
Hex #054B16

Dark Teal

Rich Black
R48 G229 B208
Hex #30E5D0

White

RO G133 B117
Hex #008575

Light Teal
White

R39 G75 B71
Hex #274B47

Dark Blue
Rich Black
R80 G230 B255
Hex #50E6FF

White

RO G120 B212
Hex #0078D4

Light Blue
White

R36 G58 B94
Hex #243A5E

Dark Purple
Rich Black
R213 G157 B255
Hex #D59DFF

White

R134 G97 B197
Hex #8661C5

Light Purple
White

R59 G46 B88
Hex #3B2E58

White
R255 G255 B255
Hex #FFFFFF

Orange
Dark Orange

Dark Yellow

Green
Dark Green

Teal
Dark Teal

Blue
Dark Blue

Purple
Dark Purple

Rich Black
RO GO BO

Hex #000000

White
Light Orange

Extra Light Gray
R242 G242 B242
Hex #F2F2F2

White
Light Yellow
Yellow

Light Gray
R230 G230 B230
Hex #EGEGE6

White
Light Green

Gray
R210 G210 B210
Hex #D2D2D2

White
Light Teal

Mid Gray

R115 G115 B115

Hex #737373

White
Light Blue

Dark Gray
R80 G80 B8O
Hex #505050

White
Light Purple

Extra Dark Gray

R47 G47 B47
Hex #2F2F2F



https://www.paciellogroup.com/resources/contrastanalyser/
https://www.microsoft.com/enable/
https://microsoft.sharepoint.com/teams/BrandCentral/Guidelines/Microsoft_color_guidelines.pdf

PowerPoint Design Ideas

Get suggestions for slides

PowerPoint Designer can create
suggestions for your slide content.

To access Design Ideas, click the
“Design” tab in the Ribbon and
then “"Design Ideas” on the right.

Designer will also trigger when
you insert an image.

. = ] Accelerating adoption of Microsoft products and services in construction industry
Accelerating adoption of Microsoft products and

services in construction industry

Accelerating adoption of
Microsoft products and
services in construction
industry

Accelerating adoption of Microsoft products and
services in construction industry




Microsoft monoline icons

Looking for icon resources?

The Monoline icon library for PowerPoint is
a slide deck that provides a library of icons
for use in PowerPoint presentations.

The Monoline icon style guide for
PowerPoint is a pdf with additional
guidelines.

Download both from Brand Central.

Monoline icon library
for PowerPoint
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https://microsoft.sharepoint.com/teams/BrandCentral/Documents/Monoline_icon_guide_and_library_for_PowerPoint.zip

Software code layout

main.js

async loadHeroes() {
this.message = 'getting the heroes, please be patient’;
await this.getHeroesAction();

this.message = 5

}s



Demo

Speaker name



Demo

Speaker name



Demo

Speaker name



=. Microsoft Dynamics 365

© Copyright Microsoft Corporation. All rights reserved.
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